User Tools

Site Tools


beewm:devel:integrating_gradle_with_eclipse

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Next revision
Previous revision
beewm:devel:integrating_gradle_with_eclipse [2014/11/21 14:30]
behullar created
— (current)
Line 1: Line 1:
-To set up a the development environment to develop bee first download the enterprise java version of the Eclipse IDE. 
-After installing Eclipse one should install the Gradle IDE plugin for Eclipse. 
  
-NOTE: When this guide was written Gradle IDE was not working with the latest Gradle version which is used by default. To be able to use it one should download Gradle 1.12 from gradle.org install it and and change the preferences of Gradle IDE to use this version. 
- 
-After installing Gradle IDE the source can be imported via the import as Gradle Project. The root folder in the import wizard should be set to the root directory of the repository then Build Model should be executed. After building the model the subproject can be selected an imported. 
beewm/devel/integrating_gradle_with_eclipse.1416576635.txt.gz ยท Last modified: 2014/11/21 14:30 by behullar